BeyondTrust

Security in Context: The BeyondTrust Blog

Welcome to the Zeroday Tracker: Your Vulnerability Watchlist

Get critical updates on the latest zeroday threats, including impact, mitigation and protection information - only from BeyondTrust.

Wellintech KingView HistorySvr.exe Buffer Overflow

Disclosed January 9, 2011    Fully Patched

Vulnerability Description:

Wellintech KingView contains a buffer overflow vulnerability when handling packets with the HistorySvr.exe module. Successful exploitation could allow remote arbitrary code execution.

Vendors:

Wellintech

Vulnerable Software/Devices:

KingView 6.53 and possibly other versions

Vulnerability Severity:

High

Exploit Availability:

N/A

BeyondTrust Prevention and Detection:

  • BeyondTrust's Retina® Network Security Scanner scans devices to detect for this vulnerability. 
    • Retina Audit 13968 - Wellintech KingView HistorySvr.exe Buffer Overflow

Mitigation:

Apply appropriate vendor patch.

Links:

CVE(s):

None

Leave a Reply