BeyondTrust

Security in Context: The BeyondTrust Blog

Welcome to the Zeroday Tracker: Your Vulnerability Watchlist

Get critical updates on the latest zeroday threats, including impact, mitigation and protection information - only from BeyondTrust.

DJ Studio Pro .PLS File Buffer Overflow

Disclosed September 16, 2009    Zeroday : 1801 days

Vulnerability Description:

DJ Studio Pro is vulnerable to a stack-based buffer overflow that occurs when handling large entries in .PLS files.

Vendors:

E-Soft

Vulnerable Software/Devices:

DJ Studio Pro 4.2
DJ Studio Pro 4.2.2.7.5
DJ Studio Pro 5.1.4.3.1
DJ Studio Pro 5.1.6.5.2
DJ Studio Pro 8.1.3.2.1

Vulnerability Severity:

High

Exploit Availability:

Publicly Available

Exploit Impact:

Remote Code Execution
Exploitation of this vulnerability is possible by sending maliciously crafted documents, via phishing emails, to vulnerable users. Remote attackers who successfully exploit this vulnerability will be able to execute code on the vulnerable system with the same rights as the currently logged on user.

BeyondTrust Prevention and Detection:

BeyondTrust's Retina® Network Security Scanner scans devices to detect for this vulnerability.

  • 31961 - DJ Studio Pro .PLS File Buffer Overflow (Zero-Day)

Mitigation:

Do not open untrusted .PLS files.

Links:

CVE(s):